Server Status

Crossplay Unavailable

Incident Report for PGA TOUR 2K Status Page

Resolved

This has been resolved with the latest patch! Crossplay should now be functional across all platforms.
Posted Mar 21, 2025 - 21:02 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 21, 2025 - 11:49 UTC

Monitoring

We have identified an issue that prevents Crossplay multiplayer from functioning correctly across the different platforms. We are monitoring the situation and will provide an update once Crossplay should be available again.
Posted Mar 20, 2025 - 19:05 UTC
This incident affected: Game Platform (PlayStation™ Network, Xbox Live, Steam Servers) and Features (Crossplay).