Server Status

Test Incident
Incident Report for PGA TOUR 2K Status Page
Resolved
This incident has been resolved.
Posted May 15, 2023 - 16:40 UTC
Monitoring
We think we fixed it, but checking
Posted May 15, 2023 - 16:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 15, 2023 - 16:37 UTC
This incident affected: Game Platform (Playstation Network) and Features (Clubhouse Pass).