Server Status

Reports of issues on PlayStation

Incident Report for PGA TOUR 2K Status Page

Resolved

PlayStation services have been restored. https://status.playstation.com/
Posted Jul 24, 2026 - 20:04 UTC

Monitoring

PlayStation services are still experiencing issues in some regions. https://status.playstation.com/
Posted Jul 24, 2026 - 17:53 UTC

Identified

We are investigating reports from players of issues accessing online services when playing on PlayStation.
Posted Jul 24, 2026 - 14:14 UTC
This incident affected: Game Platform (PlayStation™ Network).