Server Status

Minigames not working
Incident Report for PGA TOUR 2K Status Page
Resolved
This incident has been resolved.
Posted May 17, 2023 - 17:10 UTC
Update
Things are really bad
Posted May 17, 2023 - 17:09 UTC
Identified
Looking into why, stand by.
Posted May 17, 2023 - 17:08 UTC
This incident affected: Game Modes (Casual Online Matchmaking).