Server Status

Servers maintenance

Incident Report for PGA TOUR 2K Status Page

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 13:23 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 21, 2025 - 13:23 UTC

Monitoring

Servers are going down momentarily for planned maintenance.
Posted Mar 21, 2025 - 12:33 UTC
This incident affected: Game Platform (PlayStation™ Network, Xbox Live, Steam Servers).