Server Status

Steam authentication issues
Incident Report for PGA TOUR 2K Status Page
Resolved
This incident has been resolved.
Posted Jul 05, 2023 - 18:42 UTC
Investigating
We are currently investigating this issue.
Posted Jul 05, 2023 - 16:07 UTC
This incident affected: Game Platform (Steam Servers).