Server Status

Game Servers Offline

Incident Report for PGA TOUR 2K Status Page

Resolved

Posted Jun 12, 2025 - 21:08 UTC

Update

We are currently investigating the issue, more information can be found here:
https://support.2k.com/hc/en-us/community/posts/42125952431379-Server-Outage-June-12th
Posted Jun 12, 2025 - 19:36 UTC

Investigating

We are currently investigating this issue.
Posted Jun 12, 2025 - 18:51 UTC
This incident affected: Game Platform (PlayStation™ Network, Xbox Live, Steam Servers), Features (Clubhouse Pass, PGA TOUR Superstore - Featured, PGA TOUR Superstore - Equipment & Apparel, Locker Codes, Crossplay), and Game Modes (Ranked Online Matchmaking, Casual Online Matchmaking, Ranked Tours, Societies, MyCAREER, MyPLAYER, Topgolf Online, Topgolf Local, Course Designer, Private Online Lobbies, Local Match).