Server Status

Matchmaking (test)
Incident Report for PGA TOUR 2K Status Page
Resolved
Resolved
Posted Aug 28, 2023 - 22:14 UTC
Investigating
We are aware of reports of an issue with matchmaking and are investigating. (test)
Posted Aug 28, 2023 - 22:09 UTC
This incident affected: Game Modes (Ranked Online Matchmaking, Casual Online Matchmaking).